home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / audiofile-0.2.6-r1 / audiofile-0.2.6-r1.ebuild < prev    next >
Text File  |  2005-10-20  |  884b  |  36 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/audiofile/audiofile-0.2.6-r1.ebuild,v 1.15 2005/04/28 23:59:33 vapier Exp $
  4.  
  5. inherit libtool eutils
  6.  
  7. DESCRIPTION="An elegant API for accessing audio files"
  8. HOMEPAGE="http://www.68k.org/~michael/audiofile/"
  9. SRC_URI="http://www.68k.org/~michael/audiofile/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos sparc x86"
  14. IUSE=""
  15.  
  16. DEPEND=""
  17.  
  18. src_unpack() {
  19.     unpack ${A}
  20.     cd "${S}"/sfcommands
  21.     epatch "${FILESDIR}"/sfconvert-eradicator.patch
  22.     cd "${S}"
  23.     epatch "${FILESDIR}"/${P}-m4.patch
  24.     elibtoolize
  25. }
  26.  
  27. src_compile() {
  28.     econf --enable-largefile || die
  29.     emake || die
  30. }
  31.  
  32. src_install() {
  33.     make DESTDIR="${D}" install || die
  34.     dodoc ACKNOWLEDGEMENTS AUTHORS ChangeLog README TODO NEWS NOTES
  35. }
  36.